According to wordpress.org, your web host should have:

  • Apache server
  • MySQL 5.0 or higher
  • PHP 5.2.4 or higher